Los lenguajes soportados son:

PHP 5.2.17 5.3.28 5.4.x 5.5.x módulos para: MySQL, gettext, gestión imágenes jpeg y png, GDlib (Graphic Development) versiones 1 y 2, Netpbm, caracteres FreeType, criptografía
con Mcrypt, xslt-Sablotron. Compatibilidad hacía atrás para las variables globales (register_global = on), extensiones de archivo habilitadas: php, php3, phtml*

- PERL5.10.x
módulos instalados: DBI, DBD::mysql, DBD::Pg, DBD::CVS, LWP, CGI, Crypt, Digest, Net y otros. Extensiones habilitadas: cualquiera, es bastante que tengan los permisos de ejecución.

- SSI: están habilitadas, con límites en la directiva "exec cmd" para motivos de seguridad, y en su lugar se puede utilizar
<!--#include virtual="cgi-bin/nomescript" --> Extensiones habilitadas: shtml

- RUBY-1.9.2: módulos para conexión mediante interfaz mysql y postgresql

- PYTHON-2.6.x: módulos para mysql y postgresql, es lo mismo del perl para configurar nuevos.  

- BASH-3.2.x: con comandos de común utilización: sed, awk, grep, cat, ls, sleep y otros.

- C: librería estándar (stdio.h, math.h, zlib.h) gdbm, mysql, pgsql. (Los cgi en C deben ser ya rellenados y por lo tanto transferidos en el servidor de manera binaria).  

Si faltan librerías que el usuario utiliza es suficiente con rellenar el binario estáticamente para GNU/Linux con arquitectura i386.


NB: Recordamos que los script en perl, python, ruby, sh y eventuales ejecutables (como .exe o .cgi) deben ser publicados obligatoriamente en la carpeta cgi-bin, los mismos ejecutables no funcionan si publicados fuera de esta carpeta.

*La configuración de PHP y de sus variables se puede visualizar mediante el script ver.php creado dentro de cada dominio en fase de activación (o bien a través de la herramienta "Test PHP - phpinfo() " en el panel admin del dominio). Con el fin de garantizar el correcto funcionamiento del servicio y de los servidores que alojan los dominios, algunos de los parámetros PHP no podrán ser modificados. Para más información sobre este tema puede abrir un ticket de Asistencia.